Search Messages

 
Author:
Search Start Date:
Search End Date:
Sort Order
Sources to include:
OR Message ID:
 

Display Mesage #132541


Re: vacuum piston not functioning
Written by Dockstader, David R (Jefferson) on 6/22/2016 at 10:43 am

#ygrps-yiv-1442729367 P {margin-top:0;margin-bottom:0;}Yep, PCs don't run worth a darn with the air box off.

Message Thread for message #132541

jdoyle_53
6/25/2012, 01:58 am
vacuum piston not functioning
Can someone point me to a discussion or link describing the workings of the carburetor vacuum piston on a PC800? My left carb piston doesn't move ? right carb seems OK even after swapping diaphragms between sides. I left gas in it last winter

    mikeyb_houtex
    6/25/2012, 05:03 am
    vacuum piston not functioning
    Well, it's really quite elegant, and actually somewhat simple. First, though, lemme say that I find it quite interesting that you say the engine is running correctly AND the left carb's piston doesn't move. These two 'facts' simply cannot

    jdoyle_53
    6/26/2012, 05:14 pm
    vacuum piston not functioning
    Thanks Mike and “wynndungey” for your responses.  I will try the atmosphere air test this weekend, weather permitting – I tinker under a shade tree.  A bit of introspection: I have only observed the vacuum pistons at idle – too timid to cra

    mikeyb_houtex
    4/26/2013, 12:00 am
    Re: vacuum piston not functioning
    Just updating the link, as the one shown below is now wrong. Correct link is this:http://www.pc800shopmanual.org/PC800SMPage5-8.htmlTha

    neerajverma132
    6/21/2016, 11:07 am
    Re: vacuum piston not functioning
    Sorry to resurrect a dead thread but my bike was missing or slightly muffled popping sound when coasting approximately 1/4 throttle. I don't notice this noise at idle or high RPM. New plugs didn't help either. So I opened up

    Mac Hancock
    6/21/2016, 12:45 pm
    Re: PC800: Re: vacuum piston not functioning

    Dockstader, David R (Jefferson)
    6/22/2016, 10:43 am
    Re: vacuum piston not functioning
    #ygrps-yiv-1442729367 P {margin-top:0;margin-bottom:0;}

    neerajverma132
    6/24/2016, 10:53 am
    Re: vacuum piston not functioning
    I balanced the carbs with the airbox on the bike and the popping noise is gone! However I still think the bike is running a little rich due to spark plugs being a bit on the gray side. I will be going to the deals Gap / Smoky Mt trip. I would appreci

    neerajverma132
    6/24/2016, 10:54 am
    Re: vacuum piston not functioning
    I meant to say running a bit lean.

    robert_a_carr
    6/24/2016, 02:43 pm
    Re: vacuum piston not functioning
    I'd be interested in the risers. You had them installed, and all the cables reached, right? I'll be at Bryson City next month. I can PayPal now, or give you cash then. your choice. Bob CarrStem NC

    neerajverma132
    6/24/2016, 03:23 pm
    Re: vacuum piston not functioning
    They are brand new still in shrink wrap packaging from manufacturer. There are many websites with install instructions specific to the PC800. Below is a very good one from Mr. 

    neerajverma132
    6/24/2016, 03:26 pm
    Re: vacuum piston not functioning
    Cash on the spot would be fine. I will see you there on Saturday or Sunday. I am traveling with another rider on

    sr139fox
    6/25/2016, 05:15 pm
    Re: vacuum piston not functioning
    Bob. I have one inch risers. All cables fit.  Key is now in a deep socket.  Take some tools and install in the parking lot.  There is plenty of help and experience there.   Dave P