Search Messages

 
Author:
Search Start Date:
Search End Date:
Sort Order
Sources to include:
OR Message ID:
 

Display Mesage #95295


Twist throttle won't return with grip puppies installed?
Written by douglasvanb on 7/25/2010 at 08:41 am

Hi Vern,

Do you have a throttle lock on your bike? It might have gotten locked down
without you realizing it. That happened to me when I first put the grip puppies
on mine.

I ended up leaving my grip puppies long. They hang off the twisty part of the
grips and onto the bar end weights but they work just fine as long as I don't
grip on the bar ends. No problems for me with returning to idle.

I guess it could also be from rolling your grip puppies over on themselves?
Might have pinched the throttle grip too much? Otherwise my next guess would be
a busted spring or cable but I don't have much experience with throttle
cable/spring failures. (and hope I never do!)

Cheers,

Douglas

--- In ipcrc@yahoogroups.com, "verncreamer" <vccreamer@...> wrote:
>
> I just installed a pair of grip puppies and they feel perfect ... the problem
is that when I twist the throttle, it won't "rebound" or return. I have not
trimmed them, but did roll each end back over itself so that no part of the grip
is touching the ends of the throttle.
>
> What did I do wrong?
>
> Vern
> '97 PC800 unnamed
> Elkhorn, Nebraska
>

Message Thread for message #95295

verncreamer
7/25/2010, 12:15 am
Twist throttle won't return with grip puppies installed?
I just installed a pair of grip puppies and they feel perfect ... the problem is that when I twist the throttle, it won't "rebound" or return. I have not trimmed them, but did roll each end back over itself so that no part of the grip