Search Messages

 
Author:
Search Start Date:
Search End Date:
Sort Order
Sources to include:
OR Message ID:
 

Display Mesage #95297


Twist throttle won't return with grip puppies installed?
Written by c172myp51 on 7/25/2010 at 12:04 pm

My throttle, since installing GP's, has been a little sticky too. I think that
it messes with the friction of the Throttlemeister, but honestly I've just
gotten used to it. I probably shouldn't!
-Scott

--- In ipcrc@yahoogroups.com, "bty2683498" <pjcrawley@...> wrote:
>
>
>
> --- In ipcrc@yahoogroups.com, "verncreamer" <vccreamer@> wrote:
> >
> > I just installed a pair of grip puppies and they feel perfect ... the
problem is that when I twist the throttle, it won't "rebound" or return. I have
not trimmed them, but did roll each end back over itself so that no part of the
grip is touching the ends of the throttle.
> >
> > What did I do wrong?
> >
> > Vern
> > '97 PC800 unnamed
> > Elkhorn, Nebraska
> >
> Hi Vern, I just put a set of grip puppies on yesterday and had your problem at
first I worked them right over the original grips and they fitted with no
doubling over or trimming, blipped the throttle a few times and they were ok, I
just used soapy water as per instuctions to slide them on.
> Phil Crawley.
>

Message Thread for message #95297

verncreamer
7/25/2010, 12:15 am
Twist throttle won't return with grip puppies installed?
I just installed a pair of grip puppies and they feel perfect ... the problem is that when I twist the throttle, it won't "rebound" or return. I have not trimmed them, but did roll each end back over itself so that no part of the grip