Search Messages

 
Author:
Search Start Date:
Search End Date:
Sort Order
Sources to include:
OR Message ID:
 

Display Mesage #95301


Twist throttle won't return with grip puppies installed?
Written by dmikec... on 7/25/2010 at 05:34 pm

If you are going to work with the throttle, make sure you note when the housing
is at and at what angle. It took me 1 half hour to get everything aligned back
to plastic back together.

Mike

--- In ipcrc@yahoogroups.com, "verncreamer" <vccreamer@...> wrote:
>
> I am unfamiliar with cable lubricant ... what should I use?
>
> Thanks.
>
> --- In ipcrc@yahoogroups.com, "BD Pickett" <bp.ipcrc@> wrote:
> >
> > It may just be that your throttle cables need lubricating. I don't have Grip
Puppies, but I did have a sticking throttle such as you described, and after
spraying lubricant down the cable sheaths, I saw a drastic improvement in
throttle response.
> >
> > Be seeing you,
> > Bruce Pickett
> > Federal Way, WA
> > '90 PC800 "Blue Pacific"
> > '96 PC800 "Red C"
> > '93 ST1100 "STimulus"
> > '05 GL1800A "Blue's Brother"
> > http://bluepc.home.comcast.net
> >
> >
> > --- In ipcrc@yahoogroups.com, "verncreamer" <vccreamer@> wrote:
> > >
> > > I just installed a pair of grip puppies and they feel perfect ... the
problem is that when I twist the throttle, it won't "rebound" or return. I have
not trimmed them, but did roll each end back over itself so that no part of the
grip is touching the ends of the throttle.
> > >
> > > What did I do wrong?
> > >
> > > Vern
> > > '97 PC800 unnamed
> > > Elkhorn, Nebraska
> > >
> >
>

Message Thread for message #95301

verncreamer
7/25/2010, 12:15 am
Twist throttle won't return with grip puppies installed?
I just installed a pair of grip puppies and they feel perfect ... the problem is that when I twist the throttle, it won't "rebound" or return. I have not trimmed them, but did roll each end back over itself so that no part of the grip