Search Messages

 
Author:
Search Start Date:
Search End Date:
Sort Order
Sources to include:
OR Message ID:
 

Display Mesage #95303


Twist throttle won't return with grip puppies installed?
Written by docta96 on 7/25/2010 at 06:35 pm

Check to be sure that you did not cause the underlying grips to bind anywhere,
especially on the inboard end, when you installed the grip puppies, either on
the bar end weights or the throttle mechanism or any throttle lock, if you are
using one. Unless you have disturbed something or created binding, the grip
puppies should have no impact at all on the operation of the throttle cable
and/or return spring.
One one of my PCs, I had go shorten the grip puppy to clear the Throttlemeister.

--- In ipcrc@yahoogroups.com, "verncreamer" <vccreamer@...> wrote:
>
> I just installed a pair of grip puppies and they feel perfect ... the problem
is that when I twist the throttle, it won't "rebound" or return. I have not
trimmed them, but did roll each end back over itself so that no part of the grip
is touching the ends of the throttle.
>
> What did I do wrong?
>
> Vern
> '97 PC800 unnamed
> Elkhorn, Nebraska
>

Message Thread for message #95303

verncreamer
7/25/2010, 12:15 am
Twist throttle won't return with grip puppies installed?
I just installed a pair of grip puppies and they feel perfect ... the problem is that when I twist the throttle, it won't "rebound" or return. I have not trimmed them, but did roll each end back over itself so that no part of the grip