Search Messages

 
Author:
Search Start Date:
Search End Date:
Sort Order
Sources to include:
OR Message ID:
 

Display Mesage #95328


Twist throttle won't return with grip puppies installed?
Written by bdpickett on 7/26/2010 at 03:34 am

The pin sits in a hole on the forward half of the throttle housing. On the front
of the right handlebar, there is a 3mm (1/8") hole located 150mm (5-7/8") from
the end that matches up with the pin in the throttle housing. In these photos, I
have highlighted the hole by making a white circle around it:
http://bluepc.home.comcast.net/~bluepc/images/pc800_handlebar_throttle_pin_hole_\
1.JPG

http://bluepc.home.comcast.net/~bluepc/images/pc800_handlebar_throttle_pin_hole_\
2.JPG


The part numbers for the throttle housing halves are the same for all years of
PCs, however, the p/n for the handlebar itself is different for an '89 than for
the following years. Both my '90 and my '96 have pins to align the throttle
housing on the handlebar, but I can only assume that the '89 would follow suit.

Be seeing you,
Bruce Pickett
Federal Way, WA
'90 PC800 "Blue Pacific"
'96 PC800 "Red C"
'93 ST1100 "STimulus"
'05 GL1800A "Blue's Brother"
http://bluepc.home.comcast.net

--- In ipcrc@yahoogroups.com, "dmikec@..." <dmikec@...> wrote:
>
> I did not see one, I have a '89 and all I saw was two screws that held the
cable housing together and tighten it down to the handlebars. Where does the
pin go in at?
>
> Thanks,
>
> Mike
>
> --- In ipcrc@yahoogroups.com, "BD Pickett" <bp.ipcrc@> wrote:
> >
> > There should be a pin that aligns the throttle housing with a hole in the
handlebars. If the pin has become lost, it could indeed be a hassle to get
things lined up properly.
> >
> > Be seeing you,
> > Bruce Pickett
> > Federal Way, WA
> > '90 PC800 "Blue Pacific"
> > '96 PC800 "Red C"
> > '93 ST1100 "STimulus"
> > '05 GL1800A "Blue's Brother"
> > http://bluepc.home.comcast.net

Message Thread for message #95328

verncreamer
7/25/2010, 12:15 am
Twist throttle won't return with grip puppies installed?
I just installed a pair of grip puppies and they feel perfect ... the problem is that when I twist the throttle, it won't "rebound" or return. I have not trimmed them, but did roll each end back over itself so that no part of the grip